Ubuntu12.04+php5.3.10编译安装Swoole

参考:http://wiki.swoole.com/wiki/page/6.html
编译错误提示:
In file included from /usr/include/php5/ext/spl/spl_iterators.h:27:0,
from /back/soft/swoole/swoole-1.8.2/swoole.c:28:
/usr/include/php5/ext/pcre/php_pcre.h:29:18: fatal error: pcre.h: No such file or directory

解决问题:
apt-get install php-pear
apt-get install libpcre3-dev

QQ截图20160315152626
编译参数

--enable-swoole-debug  打开调试日志,开启此选项后swoole将打印各类细节的调试日志。生产环境不要启用。
--enable-sockets增加对sockets资源的支持,依赖sockets扩展。开启此参数,swoole_event_add就可以添加sockets扩展创建的连接到swoole的事件循环中。
--enable-async-mysql增加异步mysql支持, 依赖mysqli和mysqlnd扩展。
--enable-async-redis增加异步Redis客户端支持, 依赖hiredis库
--enable-async-httpclient增加异步Http和WebSocket客户端支持
--enable-ringbuffer开启RingBuffer内存池
--enable-openssl启用SSL支持